常见问题常见问题   搜索搜索   会员列表会员列表   团队团队   注册注册    个人资料个人资料   登录查看您的站内信件登录查看您的站内信件   登录登录 

[help] 关于在8.1amd64上用snd_da音频驱动左声道无声音。

 
发表新文章   回复文章    FreeBSD China -> 设备驱动
阅读上一个主题 :: 阅读下一个主题  
作者 留言
zp阿土
道童


注册时间: 2003-12-26
文章: 269
来自: 西安

文章发表于: Fri 2010-08-06 15:30:09    发表主题: [help] 关于在8.1amd64上用snd_da音频驱动左声道无声音。 引用并回复

我的Realtek ALC883声卡在FreeBSD8.1-amd64上加载了snd_hda驱动发现左声道无声音,编译到内核里还是一样。 我现在用的是GENERIC内核。 不知道哪位兄太碰到过这个问题没有?

我在/boot/loader.conf里加入snd_hda_load="YES" 起来后发现作声道无声音
# cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
Installed devices:
pcm0: <HDA> (play/rec) default
pcm1: <HDA> (play/rec)
pcm2: <HDA> (play)


最后进行编辑的是 zp阿土 on Fri 2010-08-06 17:14:54, 总计第 1 次编辑
返回页首
阅览会员资料 发送站内信件 发送电子邮件
sp55aa
道童


注册时间: 2008-03-04
文章: 371

文章发表于: Fri 2010-08-06 16:17:15    发表主题: 引用并回复

看看音量?
$ mixer

_________________
NUC: FreeBSD
PC: VBox+FreeBSD+ZFS
返回页首
阅览会员资料 发送站内信件 发送电子邮件
zp阿土
道童


注册时间: 2003-12-26
文章: 269
来自: 西安

文章发表于: Fri 2010-08-06 17:01:41    发表主题: 引用并回复

sp55aa 写到:
看看音量?
$ mixer

$ mixer
Mixer vol is currently set to 25:25
Mixer pcm is currently set to 75:75
Mixer speaker is currently set to 75:75
Mixer line is currently set to 75:75
Mixer mic is currently set to 0:0
Mixer cd is currently set to 75:75
Mixer mix is currently set to 0:0
Mixer rec is currently set to 75:75
Mixer igain is currently set to 100:100
Recording source: mic
返回页首
阅览会员资料 发送站内信件 发送电子邮件
sp55aa
道童


注册时间: 2008-03-04
文章: 371

文章发表于: Sat 2010-08-07 12:41:43    发表主题: 引用并回复

确定不是硬件问题? 我的也是ALC 833, 系统是9.0-amd64, 一直很正常的
_________________
NUC: FreeBSD
PC: VBox+FreeBSD+ZFS
返回页首
阅览会员资料 发送站内信件 发送电子邮件
zp阿土
道童


注册时间: 2003-12-26
文章: 269
来自: 西安

文章发表于: Sun 2010-08-08 00:14:54    发表主题: 引用并回复

sp55aa 写到:
确定不是硬件问题? 我的也是ALC 833, 系统是9.0-amd64, 一直很正常的

确定不是硬件问题是什么意思?? 我不太明白,是只物理方面吗?
我在xp下试了下 没问题
以前一直用FreeBSD的桌面从来没注意过声音 只是最近翻出来了几张 RayCharles和 Kenny Rogers 的cd 压成mp3 听的时候才发现只有没有左声道。
放心mp3是没有问题的 在xp下也试过了 同学copy走在他的机子上听也没问题

这两天看了 sound(4) he snd_hda device.hints(5) sysctl(Cool callout(9) 看的有点晕
还是解决不了
返回页首
阅览会员资料 发送站内信件 发送电子邮件
alphachi
老妖


注册时间: 2007-12-10
文章: 1263
来自: @tweetxa

文章发表于: Sun 2010-08-08 02:46:55    发表主题: 引用并回复

切换下模块单元看看,具体参考:

http://www.freebsdchina.org/forum/viewtopic.php?t=49406
返回页首
阅览会员资料 发送站内信件
zp阿土
道童


注册时间: 2003-12-26
文章: 269
来自: 西安

文章发表于: Mon 2010-08-09 18:14:11    发表主题: 引用并回复

alphachi 写到:
切换下模块单元看看,具体参考:

http://www.freebsdchina.org/forum/viewtopic.php?t=49406


试了下
只有在 hw.snd.default_unit=0 的时候有声音(也就是原来系统默认)
当 hw.snd.default_unit=1 的时候没声音
返回页首
阅览会员资料 发送站内信件 发送电子邮件
alphachi
老妖


注册时间: 2007-12-10
文章: 1263
来自: @tweetxa

文章发表于: Mon 2010-08-09 21:56:15    发表主题: 引用并回复

我这里有个机器,ThinkPad X200,用的就是snd_hda,设置成0和你遇到的情况一样,设置成1就好了,再不行就不知道是哪里的问题了。 Embarassed
返回页首
阅览会员资料 发送站内信件
zp阿土
道童


注册时间: 2003-12-26
文章: 269
来自: 西安

文章发表于: Fri 2010-08-13 02:06:23    发表主题: 引用并回复

这两天看资料看晕了 看的有点慌了 休息一天在看
返回页首
阅览会员资料 发送站内信件 发送电子邮件
dotyao
半仙


注册时间: 2007-06-16
文章: 79

文章发表于: Fri 2010-08-20 18:10:26    发表主题: 引用并回复

alphachi 写到:
我这里有个机器,ThinkPad X200,用的就是snd_hda,设置成0和你遇到的情况一样,设置成1就好了,再不行就不知道是哪里的问题了。 Embarassed


我也是这机器,设置成1的话,用不了外置音响或耳机。好纠结。。。每次换来换去,当然,对于虔诚的FB教徒,这不算啥。。。
返回页首
阅览会员资料 发送站内信件
syh
老妖


注册时间: 2010-05-02
文章: 1617
来自: 卡拉赞

文章发表于: Tue 2010-08-24 23:41:51    发表主题: 引用并回复

alphachi 写到:
我这里有个机器,ThinkPad X200,用的就是snd_hda,设置成0和你遇到的情况一样,设置成1就好了,再不行就不知道是哪里的问题了。 Embarassed


x200和r400估计是相通的 Smile
r400上1是音箱,0是耳机。。。

_________________
又要毕业了。应该是最后一次。
-------------
audio/mous
ports-mgmt/pkg-rmleaf
Buffer Hint: http://www.vim.org/scripts/script.php?script_id=5272
返回页首
阅览会员资料 发送站内信件
从以前的文章开始显示:   
发表新文章   回复文章    FreeBSD China -> 设备驱动 论坛时间为 北京时间
1页/共1

 
转跳到:  
不能发布新主题
不能在这个论坛回复主题
不能在这个论坛编辑自己的文章
不能在这个论坛删除自己的文章
不能在这个论坛发表投票


Powered by phpBB 2023cc © 2003 Opensource Steps; © 2003-2009 The FreeBSD Simplified Chinese Project
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Project Honey Pot and phpBB.cc
silvery-trainer
The FreeBSD China Project 网站: 中文计划网站 社区网站
The FreeBSD China Project 版权所有 (C) 1999 - 2003 网页设计版权 著作权和商标